Opened 10 years ago

Closed 5 years ago

#225 closed defect (obsolete)

error: can't allocate region

Reported by: guest Owned by: devel
Priority: normal Milestone:
Component: ARB_PARSIMONY Version: arb_5.1
Keywords: breakpoint, add marked Cc: efleming@…

Description

I recently upgraded to the 5.1 version When I try and add the species to the tree I get the command to add the sequences followed by an error (that repeats) and ends with the statement that ARB requires 3.4Gbytes of memory (I have included that below).

My network administer suggested there maybe a memory leak. I have looked at the bug reports and bug report 6176 does address a malloc_error but not with regards to allocating a region and this bug fix should have been included in the release of 5.1 (6213)

Everything "seems" to be running fine but the real question is, does does this impact my result (alignments, sequence placement etc?)

I am running the December 2009 release (5.1) of ARB on the a Macintosh a 4GB RAM with a Intel 2.4 Ghz DuoCore? Processor running OS 10.5.8 I have not upgraded to 10.6 because our laboratory printers can not yet interface with the 64-bit machines.

[Action: 'arb_pars -add_marked -quit &']

arb_pars(629) malloc: * mmap(size=2147483648) failed (error code=12)

* error: can't allocate region

* set a breakpoint in malloc_error_break to debug

  • memsize(used by ARB) = 3402394 k

Any guidance or suggestions would be most helpful.

Change History (1)

comment:1 Changed 5 years ago by westram

  • Resolution set to obsolete
  • Status changed from new to closed

I think this does no longer occur with arb6.0. Otherwise reopen the ticket.

Note: See TracTickets for help on using tickets.