Opened 4 years ago

Closed 3 weeks ago

#636 closed defect (cantfix)

ARB crashes when attempting to build a PT_Server

Reported by: guest Owned by: westram
Priority: major Milestone:
Component: Library (DB) Version: arb-6.0.2
Keywords: Cc:

Description (last modified by westram)

Hello,

Rather new ARB user here. I've been attempting to create a database and generate a PT-server, but am running into the following problem:

-------------------- ARB-backtrace 'received signal 11':
/vol/apps/user/stow/arb-6.0.2/lib/libCORE.so(GBK_dump_backtrace(_IO_FILE*, char const*)+0x34)[0x7f132c803084]
/vol/apps/user/stow/arb-6.0.2/lib/libCORE.so(+0x1072b)[0x7f132c80572b]
/lib64/libc.so.6[0x3de2e326a0]
/vol/apps/user/stow/arb-6.0.2/lib/libARBDB.so(+0x55a06)[0x7f132caa1a06]
/vol/apps/user/stow/arb-6.0.2/lib/libARBDB.so(gb_save_mapfile(GB_MAIN_TYPE*, char const*)+0x47f)[0x7f132caa1fbf]
/vol/apps/user/stow/arb-6.0.2/lib/libARBDB.so(GB_MAIN_TYPE::save_as(char const*, char const*)+0x2d7)[0x7f132ca6e987]
arb_ntree[0x5140ad]
/vol/apps/user/stow/arb-6.0.2/lib/libWINDOW.so(AW_cb::run_callbacks()+0xb7)[0x7f132c339fd7]
/vol/apps/user/stow/arb-6.0.2/lib/libWINDOW.so(AW_server_callback(_WidgetRec*, void*, void*)+0x95)[0x7f132c358ce5]
/usr/lib64/libXt.so.6(XtCallCallbackList+0x12f)[0x3dfd813bbf]
/usr/lib64/libXm.so.4[0x3de4ee7de7]
/usr/lib64/libXt.so.6[0x3dfd84a59d]
/usr/lib64/libXt.so.6(_XtTranslateEvent+0x3f3)[0x3dfd84ae03]
/usr/lib64/libXt.so.6(XtDispatchEventToWidget+0x3fb)[0x3dfd821dab]
/usr/lib64/libXt.so.6[0x3dfd8225db]
/usr/lib64/libXt.so.6(XtDispatchEvent+0xb4)[0x3dfd821614]
/usr/lib64/libXt.so.6(XtAppProcessEvent+0x269)[0x3dfd82ebf9]
/usr/lib64/libXt.so.6(XtAppMainLoop+0x2d)[0x3dfd820f8d]
arb_ntree[0x46c5b7]
arb_ntree(ARB_main(int, char**)+0x46d)[0x46d20d]
/lib64/libc.so.6(__libc_start_main+0xfd)[0x3de2e1ed5d]
arb_ntree[0x44b7e9]
-------------------- End of backtrace
[Terminating with signal 11]

'''not found(1): gbd=22f3d28
[arb_launcher[0]: 'arb_ntree' has terminated with error 139]
[arb_launcher[0]: All launched processes terminated]
'''

This occurs just after I select "Build server" in the PT-Admin window. I've attached the relevant log file.

Any insight would be appreciated!

Best,

Peter

Attachments (1)

run.log (2.3 KB) - added by guest 4 years ago.
Runlog for a short ARB session in which the PT-Admin function caused ARB to crash.

Download all attachments as: .zip

Change History (6)

Changed 4 years ago by guest

Runlog for a short ARB session in which the PT-Admin function caused ARB to crash.

comment:1 follow-up: Changed 3 years ago by westram

  • Component changed from !NoIdea to Library (DB)
  • Description modified (diff)
  • Priority changed from normal to major
  • Type changed from issue to defect

Hi Peter,

thx for reporting.

from the info you've posted i can tell where ARB crashes, but I can't guess why. A comment in the code states "should never occur" which obviously is a lie :)

Can you reproduce the crash with your DB? If yes, I would be interested to get access to your DB in order to debug and fix the problem.

Ralf

P.S.: you can add yourself to the cc-field below. Then you'll get email on each change of this ticket. Your address will only be shown to registered users.

comment:2 in reply to: ↑ 1 ; follow-up: Changed 3 years ago by guest

Hi Ralf,

I just replicated the crash, and I can certainly send you the DB to play around with. Is there an email I can send it to? I'd prefer not to make it publicly available, just for safety's sake.

Peter

comment:3 in reply to: ↑ 2 Changed 3 years ago by westram

Hi Peter,

Replying to guest:

I just replicated the crash, and I can certainly send you the DB to play around with. Is there an email I can send it to? I'd prefer not to make it publicly available, just for safety's sake.

Great. Please mail your DB to upload@… and drop me a note here.

Ralf

comment:4 Changed 3 years ago by westram

  • Status changed from new to infoneeded_new

comment:5 Changed 3 weeks ago by westram

  • Owner changed from devel to westram
  • Resolution set to cantfix
  • Status changed from infoneeded_new to closed

database never arrived

Note: See TracTickets for help on using tickets.