Opened 2 years ago

Closed 2 weeks ago

#698 closed defect (fixed)

[OSX] can't click buttons (x/y offset by window pos)

Reported by: epruesse Owned by: devel
Priority: blocker Milestone:
Component: Library (GUI) Version: SVN
Keywords: Cc:

Description

On OSX using motif, mouse clicks don't "hit" the right part of the window. There seems to be an offset proportional to the initial window position.

  • affects the window decoration as well (e.g. top bar)
  • can be fixed by maximizing and then un-maximizing window size
  • does not affect other motif applications (xpdf, nedit)

Since the issue can be "fixed" by zooming the window twice (maximize, unmaximize), and since the mouse-offset is related to the mouse position, my best guess is that it is something related to the way the window is repositioned to match the saved config.

Marking as "blocker" since this will deter 100% of affected users permanently.

Change History (4)

comment:1 Changed 2 years ago by westram

Do you have any idea since when it behaves like that?

comment:2 Changed 2 years ago by epruesse

The 6.0.3 release still works fine. I'll try to do a bisection search to narrow it down a bit more.

comment:3 Changed 2 years ago by westram

my guesses:

comment:4 Changed 2 weeks ago by epruesse

  • Resolution set to fixed
  • Status changed from new to closed

Seems to have fixed itself? Can't reproduce any longer.

Note: See TracTickets for help on using tickets.