wiki:GccVersionInfo

gcc version information

compiler/perl versions arb needs to support


Ubuntu version
(default or updated)
System compiler

Perl version
Test
frequency

Comment
10.04 LTS gcc 4.4.3 ? [!] (mgg)
12.04 LTS gcc 4.6.3 5.14.2 [!] (precise vm)
14.04 LTS gcc 4.8.4 5.18.2 [!] (trusty vm)
16.04 LTS gcc 5.4.0 5.22.1 [!] (xenial vm)
18.04 LTS gcc 7.4.0 5.26.1 [!] (bionic vm)
mint-19 gcc 7.5.0 5.26.1 (./) development
20.04 LTS gcc 9.3.0 5.3.0 [!] (fossa vm)
Debian version
7 gcc 4.7.2 ? (X)
8 gcc 4.9.2 5.20.2 [!] (jessie vm)
10 gcc 8.3.0 5.28.1 [!] (buster vm)
CentOS version
5 gcc 4.4.7 ? (X)
6 gcc 4.4.7 ? (X)
OSX version
clang 4.2.1 ? (X)

((./) frequently [!] provided builds (X) untested)

Please report when any of these version fails to build.

compiler versions known by the production version of arb (=trunk)

see source:trunk/Makefile#L106

Note: not all of these versions may be used to compile arb, see next section.

compiler versions not compatible with arb

versionforbidden?reason
gcc <4.4.3yeslowest supported gcc version is 4.4.3 = ubuntu 10.04 system compiler
gcc 4.6.4yesfails to compile inplace constructors
gcc 4.8.0yescauses undefined behavior on certain uses of bool (see #617)

arb/perl mismatch

When you encounter the error message

Incompatibility detected between installed arb build and perl version:
* arb macro playback will not work and
* other arb perl scripts wont work either.

Solution:

  • install another arb build which is compatible with your perl version
    • see perl version info in above table to guess which version could work
    • call perl -v to detect your perl version
  • (otherwise see comment here)
Last modified 4 months ago Last modified on Aug 13, 2021, 3:36:53 PM